Alfa AWUS036NHA with 15 inch Macbook pro 2018 issues

Hi,
Just bought Alfa AWUS036NHA
I have a 15inch MacBook Pro 2018 with USB-c ports.
I am using a converter to USB. I am connecting the AWUS036NHA to this
However, the AWS036NHA LED does not light up meaning it is not detected on MacBook
I think I need to solve this before going to VM - correct?

(course: Learn Network Hacking From Scratch (WiFi & Wired) by Zaid)

Could you advise on :

  1. whether AWUS036NHA is compatible with MacBook Pro?
  2. Do I have to download some drivers? Please share the link to drivers for AWUS036NHA
  3. Do I have to buy another adapter? Which model number?

Thanks

Hi Harharhari,

The AWUS036NHA is compatible with Kali for it supports monitor mode and frame injection, but it’s better to not use a hub or extension to connect it to the VM, if you can’t do this on your Mac machine, then make sure that you add the card to the USB list as shown in lecture 11. If you did, then make sure that you don’t physically connect the card to the computer until Kali is fully booted, connect the card, then go to the devices menu (beside the file menu) >> USB >> Click your device.
In addition, you can try the following when you connect the adapter to the VM:

  • Experiment with connecting the adapter before and after Kali fully loads, and after you log in as root.
  • Experiment with setting the adapter to use USB 2.0 and 3.0 in Kali system settings in Vbox.
  • Make sure you connect the adapter directly to the computer, don’t use a hub or an extension.
  • And experiment with connecting the adapter to different USB ports.

Hi AJS,
Thanks for your inputs.
Here are the things I tried (some before your reply):

  1. I have another macbook pro 2010 with OSX 10.13
    (a) There are no mac drivers for AWUS036NHA on www.alfa.com.tw.
    (b) Installed a OSX 10.13 driver from alfa.com.tw website for AWUS036NH.
    © This makes changes to your system and on rebooting the system gets stuck.
    still recovering from the mess.
    Learning : Avoid install of drivers which make system changes
  2. Installed Kali Linux on Raspberry Pi
    Having issues with my GUI
  3. Installed Kali Linux on Raspberry Pi 3
    Having issues with my display and some other issues in booting. Yet to resolve.
  4. Tried to install Virtual Box on macbook pro 2018
    It was asking for system changes and installation failed
  5. Next steps:
    (a) Recover my old macbook pro 2010 and install virtual box there and try things as suggested by you.
    (b) tinker with kali on Raspberry pi
    © Try alternately installing on basic Windows laptop which has only 4gb ram

Thanks again for your inputs !
Will keep you all posted and get back in case of issues…
Cheers !

You’re welcome Harharhari, no problem :wink:

Hi AJS and all,
Here is an update:

  1. Raspberry pi 3
    1. Installed Kali on Raspberry pi3
    2. configured AWUS036NHA adapter
  2. Windows Laptop having 4GB RAM
    1. Installed VirtualBox 6.1.4 and extensions.
    2. Installed Kali Linux 2020 VM.
    3. Configured AWUS036NHA adapter
  3. old MacBook Pro 2010
    1. Restoration was painfully long process
    2. Installation of Virtual Box 6.1.4 and extension buggy
    3. Installed Kali Linux VM but it was having issues starting.
    4. Next steps:
      1. Try older versions like Virtual Box 5.x at a later date

I think I am ready to continue the learning as I have at least basic installation of the AWUS036NHA.
Will get back in case of issues …

Thanks again !

Cheers !!

Great stuff! Glad you managed to figure it out :slight_smile: