Apt-get won't work

Whenever i try to use apt-get update commond i get an error

Err:1 https://http.kali.org/kali kali-rolling InRelease
Temporary failure resolving '[http.kali.org](http://http.kali.org)'
Reading package lists... Done
W: Failed to fetch https://http.kali.org/kali/dists/kali-rolling/InRelease Temporary failure resolving '[http.kali.org](http://http.kali.org)'
W: Some index files failed to download. They have been ignored, or old ones used instead.

I tried to change http:// to https:// but it didn’t work too

That looks like Markdown - basically a format used in documentation. Something may not have been copied to a repository source file correctly.

Check the listings in /etc/apt/sources.list and files in /etc/apt/sources.list.d to see if you can spot that [http.kali.org](http://http.kali.org) entry. Whatever repository has it is probably what is causing the error when you try to update the package lists.

sources.list.d is empty and sources.list doesn’t have any entry of this
http.kali.org

kali.org also isn’t opening in browser, it shows something like server not found
i think it has something to do with this.

Are you able to get to other web pages, like Google.com? If not, that could indicate a network problem on the machine.

If you can get to other websites, do you need to use a proxy server to make web connections? If so, apt would need to be configured to use it.

although apt-get at the command line is traditional, I think you can also just use “apt” at the command line. I think at least “sudo apt update” works the same as “sudo apt-get update” and probably “sudo apt install xxx”. Apt was developed after apt-get and a lot is the same but has a few features to make it simpler (also four less keys to type each time it’s invoked. woohoo!) I believe Kali also comes with Synaptic, which has a very nice interface and can be invoked at the command line. Maybe that’s cheating?

Yes, It was a network problem, well google was good but kali.org didn’t work but when i switched to a different network provider, it worked …