ARP spoof function

I was doing well on the “Learn Python and Ethical Hacking From Scratch” course.

I was on the ARP Spoofer chapter on the Creating an ARP Response video. I was around the 3 minute mark when the course said that the bottom IP/MAC was the windows virtual machine. I didn’t have the windows virtual machine show up in the network scanner. I’ve tried changing the network of the windows vm. I’ve tried changing the network scanner. The arpspoof function didn’t work either. I checked the Kali and Windows vms ips. The Windows vm is 10.0.2.11 and the Kali Linux vm says 10.0.2.1 and 10.0.2.3(?). I’m really not sure what’s wrong. The windows vm is on the NAT(network). The Kali Machine is on the NatNetwork. I’m on Windows 10 if that helps.

Could you help me fix this?

Thanks,

Nathan

Editors Note
I’ve solved the problem. it was the network the windows vm was on. Thank you to those who even read this. You don’t need to answer the question now. You can if you want to. I wont stop you.

Nevermind.

ok, that’s great.

about me “solving the problem”. It stopped working. it kept flashing on whether it worked or not. arp -a also cames up with 10.0.2.1 AND 10.0.2.3. Its really acting wierd.

Are you able to make a successful ARP spoof or not first? By that I mean your victim route going to your attacker machine and then from there, it goes to the router. It is shown in the " Redirecting the Flow of Packets in a Network Using arpspoof" lecture.

No. It doesn’t let me arp spoof the windows vm. It doesn’t even say that the windows vm is on the same network.

If your Windows is not on the same network then how can you do an ARP spoof? Try changing the network adaptors and see if it fixes the issue. Both systems should be on the same network route for ARP spoof to work.

Hello robodude,

I know my answer is late but if you still got the problem I may have a solution for you. One important point is, that you should give your NAT-Network a Name so you can configurate it easier at the settings of the Kali- and the Windows-vm. You can name it by going to tools, then click on settings on the left and go to the network section.
There is a Nat-Network already from the VB. The active field must be ticked and with right-click you should renamed. And don’t worry you can name it everything but I would recommend something like Router or Kali Network. After you did that, you need to go back to the Kali and Windows vm and also change their network settings to NAT-Network. Then there should be a drop-select where you must select your named NAT-Network. After this you must click on the expand button and allow Promiscuos-mode for everyone; the host and the vms. This Setting must be the changed same on both VMS otherwise it won’t work well. If this helped then the Promiscuos-mode were the error and now you should be able to see the Windos.vm IP on the Network scanner. If you have any other questions feel free to write me here :slight_smile:

Greatings,

cumbajohny