Arpspoof and bettercap not working: loosing victim connection

Hello. I am going through a hacking course of Zaid Al Quraishi. At the moment I’m stuck on one issue with the bettercap tool and arpspoof tool. When doing steps shown in the videos, the connection of my victim virtual machine (windows) loses. And I really dont know what to do, because I did all the things that I could get from the course videos and also tried to find some stuff on forums, still get nothing.

First try to make a new NAT-network.
And test everything again.

if that doesn’t work you should post a few screenshots.
(​ifconfig ​in Kali, ​ipconfig ​in the target machine, bettercap’s version, the command you used to start bettercap and the contents of the spoof caplet)

Снимок экрана 2020-09-27 в 16.09.21 Снимок экрана 2020-09-27 в 16.11.18

Снимок экрана 2020-09-27 в 16.12.30

Can you test it with this version?

Still not working :frowning:

we’re still talking about the same thing right?
You are trying to attack a windows 10 vm from a kali vm that are in the same NAT network?
Because I don’t see an ipconfig from the windows machine.
And in your spoof.cap you now have your macbook as a target.

can you describe clearly how you installed everything.
So something like Windows 10 is my host and I have virtualbox installed on it. Kali and windows are in the same NAT network ect. ect.

Alright.
First I installed vm kali on my windows 10 host machine, did all the things that I should have done just like it was shown in the course. I faced the same problem there. Then I read somewhere on forums that the router might cause the problem, so I grabbed my macbook air and tried to do all the things that I did before, using vm kali installed on this macbook with another router. So as you can guess I faced the same problem here, that I faced in windows10-kali scenario. The victim (windows 10 or mac os) just loses internet connection when I start bettercap.
I may send screenshots from the windows-kali attack like you say if it helps you see this through.

And what about windows 10 vm, I cant set NAT network for it in the preferences, because then the gateway ip changes. So I set briged adapter there. Though, that’s why I attacked my host windows machine, not the vm. Maybe thats the problem?

So you’ve been attacking your host from your kali vm?
You need to install windows 10 as a vm too.

So your host is windows 10 and install your virtualbox on it.
Then you install Kali as a VM and also a windows 10 VM.
Place them both in the same NAT network.
Here you can download a windows 10 copy for testing.
https://developer.microsoft.com/en-us/microsoft-edge/tools/vms/

The gateway should change. If they both have the same gateway its ok.

Just do what Zaid is doing in the youtube video.
And place both VM’s in that NAT-network.
And after you did that don’t forget to change the IP adress in your spoof.cap.
So something like this:
set arp.spoof.targets 10.0.2.* (only the windows 10 VM IP)

Same. Internet connection fails. I connected to the same NAT network, changed ip. Everything Zaid did. I dont think you got me right, all I did before was the same, the only thing I did from myself was that I was using wifi adapter instead of ethernet.So thats why the ip adresses changed. Thats why I had to set bridged adapter in windows vm. So, now I did everything as you said, with 10.0.2.x ip s and ethernet connection. I just dont see the problem here.
And I did attack windows vm first, I just figured that it’s faster to attack host in my case because I had to do it a lot of times to understand why connection fails. Well, it still does.

Can you now show me a “ipconfig /all” form the windows 10 VM?
And a “ip route” from the kali machine?

test
Sorry but I did everything i told you and this is the result over here.

Thats the thing, I dont understand whats the problem

And I do not have all the lines you have. Just nothing.


even this is working