Cant change wireless adapter mode to monitor

Hi, I am working through Zaid’s course on ethical hacking and was trying to set up my adapter to run in monitor mode, but got this error message.

root@kali:~# ifconfig wlan0 down

root@kali:~# iwconfig wlan0 mode monitor

Error for wireless request “Set Mode” (8B06) :
SET failed on device wlan0 ; Operation not permitted.

I am using Zaid’s custom Kali image as provided. The wireless adapter is the Alfa awus036ach which is recommended by Zaid and am 99% sure supports monitor mode, correct?

Any suggestions?

Thank you.

After some research, finally got this working:

I needed to install the chipset drivers on Kali Linux. Zaid’s video covers this here:

https://www.youtube.com/watch?time_continue=128&v=zZG65GkWGdU&feature=emb_logo

Also, for anybody else that has problems changing the MAC address:

When I ran “ifconfig wlan0 up” after changing the address I was getting an error and couldn’t get wifi back up. It’s apparently some Kernal/OS soft block. If you run ‘rfkill list all’, you’ll most likely see soft block set to yes. In order to bring your wifi back, run ‘rfkill unblock wifi’ and then run ‘ifconfig wlan0 up’ and you should be good to go.

1 Like

This link should be useful for people who might run into this issue:

It gives you a myriad of options to get your wireless adapter into monitor mode.

https://www.cellstream.com/reference-reading/tipsandtricks/410-3-ways-to-put-your-wi-fi-interface-in-monitor-mode-in-linux

1 Like

you can use airgeddon script to put you interface in monitor mode.(sometimes we need to be a script kiddie)