Can't inject packets

I was able to do the fake authentication, but despite repeated attempts I could not generate any ARP requests. This means the injection technique did not work.

After successfully changing the AP to OPN (and setting it to -2 so it kept regenerating - successfully), I used:
aireplay-ng --arpreplay -b 00:11:95:78:62:D0 -h 00:c0:ca:96:c9:ba wlan0mon

and got:

12:55:53 Waiting for beacon frame (BSSID: 00:11:95:78:62:D0) on channel 6
Saving ARP requests in replay_arp-1202-125554.cap
You should also start airodump-ng to capture replies.
^Cad 15299 packets (got 0 ARP requests and 354 ACKs), sent 0 packets…(0 pps)

I let it go up to over 30000 packets, but nada.

I also tried:
aireplay-ng -2 b 00:11:95:78:62:D0 -d FF:FF:FF:FF:FF:FF -t 1 wlan0mon
Where:
-2 means interactive replay
-b 00:14:6C:7E:40:80 selects packets with the MAC of the access point we are interested in
-d FF:FF:FF:FF:FF:FF selects packets with a broadcast destination
-t 1 selects packets with the “To Distribution System” flag set on
wlan0mon is the wireless interface

I tried this on two different Kali systems: one was a VB version, the other was a dedicated laptop running Kali as the OS. I also tried two different APs, one by dlink and the other an old Linksys.