compilation error

Hi Jesse
I have enrolled myself in your Kali Linux Hands-on Penetration Testing Labs. My receipt number: 16878968. Product ID: 624498.

I use the virtual machine on window 7 PC Where I run Kioptrix level 1.

I run Kali Linux i386 (32-bit) version 4.17.0 in my old 32-bit laptop (standalone Linux Machine).

my network is 10.1.1.0/24 and VM was set on 10.1.1.128 (DHCP).

everything is running fine up to 2nd video (7:00 min).

Now my problem starts

  1. enum4linux does not show the Kioptrix Samba Server version.

  2. Also as per your 2nd video 10.c to use for Bruteforce attack. My Kali Linux OS Does not have 10.c file. I might figure it out equivalent file could be - "/usr/share/exploitdb/exploits/linux/remote/55.c".

However, I am getting series compilation error while doing gcc 55.c -o exploitsamba. Please help.

  1. If I know root password of kioptrix I might play with it more. How do I know Kioptrix level 1 root password?

Regards

Aditi

Hey Aditi,

This video was recorded a while ago, which is why there’s a couple differences with the current versions you’re working with.

  1. There’s a known issue with the current version of enum4linux not showing the Samba version. The best other option is using Metasploit’s auxiliary module.

https://www.rapid7.com/db/modules/auxiliary/scanner/smb/smb_version

  1. You’re correct, the name has changed, but it’s the same exploit. Part of learning how to pentest is to know how to find exploits online, and create them on the fly if needed. With the knowledge of the vulnerable Samba version, you should be able to find it online or on Kali if it’s already there. Here’s the exploit-db link.

https://www.exploit-db.com/exploits/10/

I verified that 55.c does have a bunch of compilation errors, which would require you to clean up the code. Unless you’re well versed in coding c, I would suggest you download the exploit from the above link (it has no compilation errors).

  1. I don’t believe the root password is publicly known, but once you get root with this exploit you can change it to whatever you want.

Good luck!

Hi Jesse
Thanks for your reply.
----------------------

  1. I managed to find the samba version through Metasploit.
    for me it is
    msf > use auxiliary/scanner/smb/smb_version
    msf > set RHOSTS
    msf > run

  1. Now I found 10.c in my Linux machine.
    My location is
    /usr/share/exploitdb/exploits/multiple/remote/10.c, under the title “Remote Code Execution”.

  1. I managed to change my root password of my Kioptrix VM.
    Thanks
    Once again.