Deauth attack using aireplay-ng

Hey all, thought I’d contribute.

I ran into an issue attempting the deauth attack in section 6 of " Learn Ethical Hacking From Scratch".

aireplay-ng --deauth 1111 -a (macadress-of-ap) -c (macadress-of-client) wlan0

When I would attempt to send the above command, I would get this error:

“Waiting for beacon frame BSSID (mac address)”
“No such BSSID available.”

After some searching on the internet and fruitless thinking it was the drivers for my AWUS036ACH to blame,
I was able to complete the task by adding “-D” before the wlan0

aireplay-ng --deauth 1111 -a macadress-of-ap -c macadress-of-client -D wlan0

This apparently stopped the it from waiting for a response from the beacons.

So I was able to successfully disconnect my wife’s iphone from the wifi.

Thanks for this Andrew. I hope this would help other students execute the deauth without any issues…

1 Like

Thanks a ton brother… i was stuck on this issue for a long time !!!

Thank you so much. I had the same issue and after hours of searching I have finally solved it. Thanks again