Eth0 inet not showing

Hi guys, my IP doesnt show on the ETH0 part. When i use ifconfig it doesnt show the inet in eth0 section.

Hi, what all interfaces are shown apart from eth0? Sometimes the correct interface is other than eth0. Also, if your correct interface is eth0 and you don’t see the inet part then you can try restarting the networking using sudo systemctl restart networking and disable and enable the interface using ifdown eth0 and ifup eth0. You can also try changing your network adaptor in your VM settings