Installing Kali on vmware



I keep getting these messages when trying to import kali on vmware. Can someone help?

1 Like

Test it with this version of vmware.

https://customerconnect.vmware.com/downloads/get-download?downloadGroup=FUS-PUBTP-2021H1

https://kb.vmware.com/s/article/84273

Thanks. I have downloaded from the link you supplied. But now its saying ‘This virtual machine cannot be powered on because it requires the X86 machine architecture, which is incompatible with this Arm machine architecture host’ :triumph:

which mac do you have?

Macbook Air 13 inch

That doesn’t say much lol
Which processor?

Apple M1 processor

Did you try the M1 version from this source?

https://zsecurity.org/download-custom-kali/

And read this : Installation - You will require Parallels Desktop to run this VM. Download from the App Store

But you also try it with the VMware download I shared above. The M1 chip is great but not for VM’s.

Thanks, I will try again tomorrow and let you know.

Right, tried installing the M1 Kali with the vmware you recommended, still no joy!! I’ve installed the Parallels Desktop windows 11 and its asking me to subscribe its £70!!

I have an iPhone an M1 MacBook pro an Apple TV. So you can say I’m a fanboy. Only for my virtual lab I still just use a cutom build desktop with Windows. This always works flawlessly + never weird bugs and other craziness.

Do you pay for the parallels desktop?

I don’t use parallels.
I use Windows + VirtualBox for my lab.

AMD ryzen with 12 cores / 24 threads + 64gb mem.

Hello I have a problem installing the custom Kali on Windows 10 using this course: Learn Ethical Hacking From Scratch/ Installing Kali Linux as a VM on Windows. The VMware doesn’t see the image at all, it seems like there is a problem with the image itself. Can anyone help me please? Thanks!

Where did you install the Kali image from. Also can you share the screenshot of what steps you are taking to open the inage in the VM?

Hello!
So I am using this vmplayer: VMware Workstation Player | VMware
I have downloaded both images and tried them both separately following exactly the instruction video: Kali Customized.
Step1 : Downloaded the image, Step 2 used 7-zip and extracted the folder. Step 3 Opened VMware Workstation and searched for the folder, opened the folder and VMware does not recognise the image, tried “view all file types” and selected it and again it did not recognise it. Here are the screenshots:




You are trying to install a .vmdk file as an iso.
That’s not going to work.
You have 2 options
Or you download the .iso
https://zsecurity.org/download-custom-kali/
Or you do this.

2 Likes