Kali via VMware unable to detect networks in Managed Mode

I am running Kali using VMware Workstation 14. I have a NAT connection through my host Windows machine that works fine. I also have an Alfa AWUS036NH wireless adapter. When I run the Alfa, it works great in monitor mode and I am able to scan for networks. When I run it in managed mode and try to connect to a wireless network, it does not detect wireless networks at all. Nothing comes up on the list. Has anyone seen this before? Any suggestions?

Hi Dnercesian,

Can you tell us which course are you taking please?
This adapter has issues while using it in a virtualization software whether Vbox, VMware…etc, though it works perfectly on Kali as a main OS. Anyway, please try the following suggestion to fix the issue:

ifconfig wlan0 down
airmon-ng check kill && rfkill unblock all
iwconfig wlan0 mode managed
service network manager restart
nmcli radio wifi on
ifconfig wlan0 up

Try also to plug the adapter into different USB ports on your PC, and try to update Kali then upgrade by: apt-get update && apt-get upgrade && reboot (might take some time).

There’s also a suggestion with registry keys that might helps:

  1. Open the Windows registry, by clicking Start > Run and typing regedit.
  2. Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class{36FC9E60-C465-11CF-8056-444553540000} .
    “HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Control > Class > {36FC9E60-C465-11CF-8056-444553540000}”
  3. In the right hand panel, if the the UpperFilters entry exists, delete it.

Please don’t forget that the USB needs to be enabled on your host, in order for the filter to capture it.