Learn Ethical Hacking From Scratch - Gathering More Sensitive Info

Hi,

I am using nmap in Kali with Quick scan plus and I am not seeing my router like Zaid sees his. Here is my setup.

Windows 10 laptop running Win10 and Kali VMs in VMWare.
Laptop is using a wired connection to the router.
Subnet of laptop and the 2 VMs are 192.168.196
I logged into my Linksys router and it shows an ip of 192.168.1.1. Is this the reason I can’t see it? Why is it not on the same subnet of the other 3 devices?

thank you!
Mike

If you put the kali vm in bridged mode instead of nat/ nat network. (and it uses dhcp or is in the same range). then you can communicate with your router.

Thanks for the reply. I changed it to bridged and now I don’t have any connection. Here are a couple of screenshots.

settings

ifconfig

You can try adding second adaptor with NAT which will allow the internet connection. So your first adaptor will be Bridged and second NAT.

Thanks for the reply! So add a usb wireless adapter to my host laptop and set that to NAT?

Yes you can use a wireless adaptor directly connected with your laptop. Other than that you can try creating 2 network adaptors in your VM - one NAT and other Bridged. That might also work