Learn Ethical Hacking from Scratch (Module 21) - Clients (Stations) are always empty with Alfa AWUS036ACH

I’ve installed latest Kali Virtual Box, updated, updgraded kernal to latest, installed dkms driver for Alfa adapter and made built the aircrack-ng/rtl8812au driver from github and still no clients showing up when I run airodump. the commands I use:
apt-get update && apt-get upgrade
apt-get dist-upgrade
apt install realtek-rtl88xxau-dkms
airmon-ng check
airmon-ng check kill (to kill network managers)
iwconfig wlan0 mode monitor
macchanger --random wlan0
macchanger --show wlan0
ifconfig wlan0 up
airodump-ng wlan0
airodump-ng wlan0
airodump-ng —channel —bssid wlan0

Update 1:
Running this command:
aireplay-ng -1 1 -a wlan0
Allows me to see my own routers bssid and client (Alfa usb wifi adapter) mac address
This didn’t help except that I know packet injection is working

Update 2:
I’ve tried re-installing Kali and the realtek drivers as well as purging the drivers and resinstalling and manually making and installing the module from scratch as seen on the aircrack-ng/rtl8812au git repo and no change. Can see all the networks, but no stations when I hone in on mine link in module 21. I streamed 3 videos at the same time on my windows vagrant and the frames skyrocketed on the network but no station showed up. I powered down the vm and restarted it to force it to reconnect and no dice… at a dissapointed loss…

Update 2.5:
I attempted to build a Kali 2017.3 Virtualbox instance but couldn’t get the old versions of the realtek driver. Even thougb I was able to get the correct linux headers, everytime I tried to install anything beyond the original iso I got mirror errors (I’m assuming because the berkely.edu mirrors don’t exist for those needed libraries anymore due to age deprecation.)

Update 3:
I recently purchased the AWUS036NHA because it has the Atheros AR9271 chipset which is supported natively in Kali Linux and the same issue is occurring, while I can see all the networks and can packet inject, using the aircrack-ng suite, when I focus in on a single network (in this case mine) I can’t see any stations (clients) even though I have multiple devices connected to the network. It appears I can see stations if I monitor a separate network. I’m wondering if this is a networking problem with virtualbox. The module for setting up Kali says to set the network to nat network, but it doesn’t show any advanced settings.

What are those settings supposed to be?

Thank you in advance for your assistance

Update 4:
apt-get update && apt-get upgrade
apt-get dist-upgrade
apt install realtek-rtl88xxau-dkms
sudo ip link set wlan0 down
sudo ifconfig wlan0 mode monitor
sudo ip link set wlan0 up
airplay-ng wlan0 -9 (to test injection)
airodump-ng wlan0
iwconfig wlan0 channel 1
airodump-ng —channel —bssid wlan0

In separate terminal window
aireply-ng —death 10000 -a -c wlan0

Special thanks to this medium author… I pieced my solution together from his excellent explainations

Note: This solution works for both chipsets listed above