MITMF install issues

Hi Guys,
I am having problems installing the MITMF framework. I have tried several times following various online tutorials and each time it has got so far then failed. I have had to ditch several snapshots and start again but I still can’t do the course because I don’t have the tools. (Thank god for snapshots!!)
The course is presented as if MITMF is already installed and I AM using Kali 2017 as directed in the setup but it aint there!!.
Can anyone point me to an easy install for the MITMF that works.
Many thanks

I thought a simple apt-get -y install mitmf would work. What kind of trouble are are having?

Hi Tiron,

Thanks for getting back to me.

I reinstalled MITMF and am back to my original problem the output from which was…

Traceback (most recent call last):
File "./mitm.py, line 36, in
from plugins import *
File “/usr/share/mitmf/plugins/filepwn,py”, line 72, in
from bdfactory import pebin
ImportError: No module named bdfactory

Can you direct me?
Many thanks

I have tried like you did and got nothing. However, there was an announcement for a new version of Kali coming out on 18th February so I waited a few days to see if there is any difference.

I managed to get it running following the github instructions.

apt-get install python-dev python-setuptools libpcap0.8-dev libnetfilter-queue-dev libssl-dev libjpeg-dev libxml2-dev libxslt1-dev libcapstone3 libcapstone-dev libffi-dev file
git clone https://github.com/byt3bl33d3r/MITMf
cd MITMf && git submodule init && git submodule update --recursive
pip install -r requirements.txt

After that you can check

python mitmf.py --help

or go strait to

python mitmf.py -i interface
2 Likes

thank you sir!! That really worked. now I am getting this error,

Traceback (most recent call last):
File “mitmf.py”, line 139, in
from core.sslstrip.StrippingProxy import StrippingProxy
File “/root/Downloads/MITMf-master/MITMf/core/sslstrip/StrippingProxy.py”, line 20, in
from ClientRequest import ClientRequest
File “/root/Downloads/MITMf-master/MITMf/core/sslstrip/ClientRequest.py”, line 37, in
from ServerConnection import ServerConnection
File “/root/Downloads/MITMf-master/MITMf/core/sslstrip/ServerConnection.py”, line 28, in
from user_agents import parse
ImportError: No module named user_agents

1 Like

pip install user_agents

i followed all the step i get this error
File “/home/sodead/MITMf/mitmf.py”, line 38
print get_banner()
^
SyntaxError: invalid syntax

Are you using python3? In python3 that will be invalid syntax because you need to put brackets. It should be like this - print (get_banner())

i’m accually getting the same error , could you tell if you solved it?and how?

Did you read through all the comments above? The answer is already given above? If you still are getting an error then attach a screenshot of it

Sir I am having issue with MITMF

The error is because of the print statement. For python 2 the print doesn’t include parenthesis but for python 3 you have to put parenthesis. So it will be print ()

Can you please just write the excat code. Because personally i don’t understand where to put the parenthesis.
┌──(root💀kali)-[~/MITMf]
└─# python3 mitmf.py --help
File “/root/MITMf/mitmf.py”, line 38
print get_banner()
^
SyntaxError: invalid syntax

┌──(root💀kali)-[~/MITMf]
└─# python3 print get_banner(mitmf.py) --help 1 ⨯
zsh: number expected

print(get_banner())

It is highly advised that students understand the basics of Python scripting before diving into these courses. Just copying and pasting without knowing what the code does will not teach anyone anything in the long run.

sir, after that statement, there are plenty of lines shows errors and import statements also showing errors.

Those errors mean you don’t have the libraries installed to run the code. You have to install using pip install <package_name> to install those libraries. If you don’t have pip just google how to install pip and then install those libraries which show not found

you are using python3 for that and this code was written in python 2.7
to fix this:

first install future module with:pip install future

than write command: futurize -w .MITMf

and you can now run without error

type or paste code here

have you fix this error please
i’m presently facing this error how can i fix it please

how can i solve this error please
Traceback (most recent call last):
File “mitmf.py”, line 139, in
from core.sslstrip.StrippingProxy import StrippingProxy
File “/root/MITMf/core/sslstrip/StrippingProxy.py”, line 20, in
from ClientRequest import ClientRequest
File “/root/MITMf/core/sslstrip/ClientRequest.py”, line 25, in
import dns.resolver
ImportError: No module named dns.resolver

are you using python3 or python2? If python3 then I would recommend using python3 or use future to update your code