Mitmf Not Loading HTTP Sites

Trying to use mitmf to perform arpspoofing and packet sniffing but http sites on my target (Windows VM) are not loading and the https traffic is not logged.
Tried with both NAT network (eth0) and wifi (wlan0).

I don’t know about mitmf, but I would suggest you use Bettercap as it has the same features and more in Bettercap.

can you please help me in downloading MITMf. Please it would mean a lot to me

Mitmf has been archived by the creator of that tool. They recommend using Bettercap. Still if you want to install mitmf, you can look at the installation instructions on their GitHub - https://github.com/byt3bl33d3r/MITMf

i tried default instructions but it didnt work for me, i tried every tutorial on youtube, nothing worked. Bettercap is good but i took Zaid Sabih’s learn ethical from scratch and he used and showed mitmf and i dont know how to inject keylogger through bettercap

Yeah, it will mostly not work just because the project was archived. At the time of creating the video, the project might have been active with proper issues being rectified but not now. There are many bettercap videos too in the courses.