My kali doesn't have right-to-left override in characters app

I am doing the Zaid course “spoofing.exe extension to any extension(jpg,pdf…)”
Zaid goes to all apps and brings up characters app and in there he searches for right-to-left override app and uses this function. My kali system doesn’t bring up right-to-left override with searching for it in Characters app.
Thank you.

Hi @atkrsoft, Are you using the custom Kali Linux by Zaid ( Also, you can install the character map using sudo apt install gnome-characters

Thank you. Yes I use the custom Kali by Zaid. I applied “apt-get upgrade” and it added another 130ish mb and I am not sure what it upgraded. It asked me to do kind of partitioning for multiple operating systems which I refused and now when I try to log in, there is a user id KALI but it gives me the option to put my username root and password toor in there and log in. Now the search finds the right-to-left override. Hopefully upgrading Kali like that doesn’t cause more errors later on. Thank you.

I would suggest not to upgrade Zaid’s Kali. There are many tools that will break if you upgrade. Hopefully everything works now, but in the future keep this in mind.

Thank you. I was impatient and had already upgraded kali before you answered me. However,no errors yet. I have a kali snapshot couple weeks old I might restore to that version if I encounter errors in the current upgraded version of kali. Is it a sound idea in ur opinion?

Yes, I like the idea of restoring to old one if something comes up.

apt-get install gnome-characters
it will fix your problem

1 Like

Please paste that character here so that I can copy that

It worked for me.

I make sudo apt install gnome-characters but it haven’t right-to-left-override

1 Like

Did you find any solution to this bro?

I did this but still the app don’t have the right to left character.

What’s the solution bro?

You may try to use this website for it - U+202E RIGHT-TO-LEFT OVERRIDE - Unicode Explorer