Not running the first backdoor [solved]

I just want to start running my first backdoor created in Veil 3.0 but i cant’ open it on my virtual Windows machine.
I followed step by step your indications but that’s the screen that appears to me.

Both are connected to the NAT Network and also the first command -where you put the Kali Machine IP Adress on the browser- worked perfectly.

What could be the solution?

See I have a directory called evil-files in /var/www/html, so you can either:

  1. Create a directory and call it evil-files in /var/www/html, put your backdoor there, and download it it from http://10.0.2.15/evil-files/backdoorName.exe or;

  2. Put your backdoor in /var/www/html and download the backdoor from http://10.0.2.15/backdoorName.exe

Thank you for your quick answer.

I did the given steps but unfortunately i could’t open the backdoor.

This is very strange, see the webserver is working but its not finding your files, the only thing I can think of is if the web root directory was changed, maybe you accedentally did that or some package modified it?

Anyway you can reset apache2 to use whatever you put in /var/www using the following command

cp /etc/apache2/sites-available/000-default.conf /etc/apache2/sites-enabled/

And delete the browsing data from the browser (history, cookies ….etc) and try again.

If that didn’t work then try to go back to the fresh snapshot (if you have one), or right click the Kali machine in virtual box >> remove, then go to C:\Users\xxx\VirtualBox VMs\ and remove the ‘Kali’ folder if it still exists, now download a fresh .ova image and import it.
PS: Creating and using snapshots is covered in lecture 9.

Finally we could get the downloadable page! I just reset apache2 with: cp /etc/apache2/sites-available/000-default.conf /etc/apache2/sites-enabled/

sir it important to make both kali and windows on the same network

My windows vm is not seeing my kali vm through its browser either, so I entered that command:
cp /etc/apache2/sites-available/000-default.conf /etc/apache2/sites-enabled/
but the response from terminal is:
missing destination file operand after “that command”…
and suggestions other than importing the .ova file again?