OpenVAS/GVM - Login info is misssing

Hi there!

I am having some issues installing and running GVM (formerly OpenVAS).

I am able to install it, run the initial setup but here the login info is not created, or at least not shown in the terminal. Then, once I run gvm-start I cannot create the admin user with the instruction that is in the video. I know I have to type gvm instead of openvas but it doesn’t work. I tried already two different ways.

sudo runuser -u _gvm - gvmd --create-user=admin

sudo gvmd --create-user=admin --role=Admin

Both ways are not working.

Could someone please help me figuring it out how to create the admin user so I can login into the webpage?

Thanks a lot

Try following this script: https://github.com/anubisthejackle/kali-openvas-install. It installs gvm with sudo privilege account

Hi,

Thanks for your help and the link you provided.

I installed the script as indicated.

Unfortunately, there is still something wrong, for I still cannot login.

image

Did you execute that command with sudo? Why do I see a Permission denied error in your terminal?