OS Detection using nmap

Hey,

I tried to scan and detect OS of the systems behind my Home Router, using nmap 192.168.0.1-255 -O
followed by –osscan-guess and –osscan–limit

All of them are able to determine the Router’s OS but OS for other discovered devices could not be determined .

They all stated ‘Too many fingerprints match this host to give specific OS details’ - What is that fingerprint thing?


At the office, I tried to use nmap, but I wasn’t able to ping any device or site except the Localhost.
What could be the reason for this, and how do I get through this?


++I found Zenmap very helpful. It gives the Network Map. (The reason I felt excited to pursue Nmap for)

Its common that machines that are behind routers/proxies/firewall don’t get their OS determined correctly. This is because not enough information is available to nmap.

A fingerprint is a signature that patches a known OS.

When you say you were not able to ping? What do you mean? ICMP ping or do you mean that none of the nmap network discovery methods worked? Are they behind packet filtering devices? Do they run personal firewalls? On a local network, you can do discovery even with ARP. e.g. nmap 192.168.1.1-1/24 -PR

How to solved this problem im here finished now,