Pynput won't download

I wad doing fine on the course I’ve been doing for a year. Zaid’s “Learn Python and Ethical Hacking from Scratch” course. On was on the keylogger section. I was on the second lecture. The lecture said I need to install pynput. This is where the problem comes in. I tried every way I could to get it installed but nothing worked. Pip3 gave the same error as regular pip if you’re wondering. Could someone help me fix this? Any help would be appreciated.
image
image

I tried installing pynput on both python 2.x and 3.x and I was successfully able to do it.

Also, use python 3.x as python 2 has been deprecated. python 3 is the way to go

Would the command be ‘pip3 install pynput’ or is there some other stuff I need to add

I tried ‘pip3 install pynput’. It gave pretty much the same error as the error I got for ‘pip install pynput’. So I can cross that out.

here’s a picture

Is there a difference if I use the QTerminal instead of Terminator?

I just tried using the QTerminal instead of Terminator. Same results.

It is the issue with pip. maybe try this command: python -m pip install pynput

Um I acidently deleted python 1 a while ago. using python2 instead just gives the same error as literally every other command I’ve used.

How can I install a FUNCTIONAL python 1?
Usually when I get python from the website it gives a giant folder that’s nothing like the file that ran python that was pre-installed with kali. The one that was preinstalled was an individual file. When I download python, it gives me a folder.
Edit: is there another tab of the python website for Kali Linux downloads? if there is, where is it?

Oh nevermind I got it to work this time. Thanks for all the help Apurv-StationX. :slight_smile:

1 Like