[Resolved] Module 69--Learn Ethical Hacking From Scratch--Veil-Evasion Frameowork Error

I’m currently working on module 69 on the Learn Ethical Hacking From Scratch Course about Veil-Evasion Framework. I’m getting this error after naming the payload:

[!] ERROR: Unable to create output file. [!] Internal error #2. Unable to generate output. Please run /root/Veil-Evasion/config/update.py manually

So I run the command and get this output:

Veil-Framework configuration:

[] OPERATING_SYSTEM = Kali
[
] TERMINAL_CLEAR = clear
[] WINEPREFIX = /root/.config/wine/veil/
[
] TEMP_DIR = /tmp/
[] MSFVENOM_OPTIONS =
[
] METASPLOIT_PATH = /usr/share/metasploit-framework/
[] MSFVENOM_PATH = /usr/bin/
[
] PYINSTALLER_PATH = /opt/veil/PyInstaller-3.2/

[] VEIL_EVASION_PATH = /root/
[
] PAYLOAD_SOURCE_PATH = /usr/share/veil-output/source/
[] PAYLOAD_COMPILED_PATH = /usr/share/veil-output/compiled/
[
] GENERATE_HANDLER_SCRIPT = True
[] HANDLER_PATH = /usr/share/veil-output/handlers/
[
] HASH_LIST = /usr/share/veil-output/hashes.txt

[] VEIL_CATAPULT_PATH = /Veil-Catapult/
[
] CATAPULT_RESOURCE_PATH = /usr/share/veil-output/catapult/

Configuration File Written To ‘/etc/veil/settings.py’

Then I try to generate the payload again and the same error occurs. Is there something I need to change in order to generate the payload? Veil and Kali Linux are both up to date.

Hello Codyjacks,

This seems like a bug with the latest version of Veil, you’ll only get this if you set the sleep, so leave that out for now and generate a backdoor witout changing that option, if you want to change a few things to bypass more AV programs you can change the processors mad the CLICKTRACK.
setting the CLICKTRACK option will number of clicks before executing the payload, so lets say you did
SET CLICKTRACK 2
Then the payload will not get executed when the person double click it, it will wait for the target to click their mouse twice and then it will execute the payload, therefore make sure you set it to something small so that you won’t have to wait for too long.

Let me know if you need anything else,

Thank you!

Ok, but there isn’t even an option to set the sleep. When Veil starts this is what I run:

list

use 15 (which is a reverse https using go and meterpreter)

options

Here is what comes out:

Payload: go/meterpreter/rev_https loaded

Required Options:

Name Current Value Description


COMPILE_TO_EXE Y Compile to an executable
LHOST IP of the Metasploit handler
LPORT 8443 Port of the Metasploit handler

Available Commands:

set         	Set a specific option value
info        	Show information about the payload
options     	Show payload's options
generate    	Generate payload
back        	Go to the main menu
exit        	exit Veil-Evasion

So it’s different than what’s in the module 69 video. I just figured sleep wasn’t included in the options because Veil had been updated since the video had been made. This is what I do next:

set LHOST [host ip name]
set LPORT 8080

This is what was done in the video. Then I type “generate” and keep the payload name the same. What pops up next is the error that was in the first post.

Hello Codyjacks,

What do you see when you run options? Do you see a list of options for you to change, including SLEEP? You can try different payloads and see if there are any other options. Alternatively you can try DISKSIZE, try playing around with 1-5-10 values.

Let me know if you need anything else,

Thank you!

When i run options, what appears is what I listed in my last post. No options for SLEEP. I tried all the different types of payloads in Veil like you said but none of them list options for SLEEP or DISKSIZE. Are you running the most up to date version of Veil-Evasion Framework? I just reinstalled Veil 3.0 from Github and ran through all the above again and still got all the same errors.

Hello Codyjacks,

Yes I am running the latest Veil Framework.

You are using Veil evasion or this:

Please use this instead. Veil Framework.

This is what I am using and it is working fine.

Let me know if you need anything else,

Thank you!

I’m embarrassed to say I wasn’t using the most updated version of Veil. Whoops. I followed the link you provided and ran a clean install from Github. Here is what I did:

cd Veil
./Veil.py

But I get this error now:

Traceback (most recent call last):
File “./Veil.py”, line 87, in
the_conductor = orchestra.Conductor(args)
File “/root/Veil/lib/common/orchestra.py”, line 23, in init
self.load_tools(cli_stuff)
File “/root/Veil/lib/common/orchestra.py”, line 65, in load_tools
name.replace("/", “.”).rstrip(’.py’), name)
File “/usr/lib/python3.6/imp.py”, line 172, in load_source
module = _load(spec)
File “”, line 684, in _load
File “”, line 665, in _load_unlocked
File “”, line 678, in exec_module
File “”, line 219, in _call_with_frames_removed
File “Tools/Evasion/Tool.py”, line 16, in
from Tools.Evasion.evasion_common import shellcode_help
File “/root/Veil/Tools/Evasion/evasion_common/shellcode_help.py”, line 30, in
import Tool as Ordnance_Import
ModuleNotFoundError: No module named ‘Tool’

I’ve tried installing again but I get the same error. Googled this error and someone had fixed it by saying that they hadn’t selected a mirror for download. Another place said I’m missing a module but I don’t know how to install this “Tool” module. Any idea how to do either of those?

Ok, I went to Github and posted my issue and worked through it with the developer. I managed to get it resolved. I believe the cause of the issue was my version of Kali.

I went to https://www.offensive-security.com/kali-linux-vmware-virtualbox-image-download/ and downloaded the latest virtualbox image. Then I installed Veil from the Github repository (don’t do it via apt!). Everything worked fine after that.

I thought the Veil problem would have been resolved if I just ran apt-get update && apt-get upgrade and apt-get dist-upgrade on my current version of Kali but even then, it didn’t work. I had to get an entire new Kali iso.

Quick update: If you are having this issue, someone smarter than I figured out why downloading the Kali image worked for me. Turns out that apt-get remove doesn’t quite uninstall it. That’s why a new Kali image worked as a solution for me. If you don’t want to reinstall Kali, he has code that you can run to fix the issue. To read more, go here: https://github.com/Veil-Framework/Veil/issues/143

Hello CodyJacks,

Thanks for sharing!

Let me know if you need anything else,

Thank you!

1 Like

Hey!
I haven’t set sleep but still it is unable to generate the output file.
Can you help me with this.
however it was running fine few days back.