[RESOLVED]NAT Network Virtualbox - No internet access

For some reason NAT Network setting doesn’t want to connect to internet. My Windows 10 guest doesn’t want to connect either. It doesn’t connect in Metasploitable as well but NAT doesn’t work in Meta too. It was earlier.

I have tried flushing iptables and turning off host firewall but that doesn’t seem to affect anything.

I’m currently using 10.20.14.0/24 for the NAT Network

The IP i get in Kali is 10.20.14.4, Win 10 guest is assigned 169.254.10.44

I spent hours trying to find a solution online for this problem but there doesn’t seem to be anything at all out there.

when you say windows 10 guest, do you mean the laptop who’s hosting the virtualbox installation?
if yes, it’s simply because your windows 10 don’t have any ip address set
the 169.254… is an ARPA ip wich mean in recent days that you wasnt able to comunicate with a dhcp serveur (usualy your home router)

on the laptop with virtualbox, are you able to go on the internet?

My host for the VMs is Windows 7 pro. By guest I mean the Virtual machines I am running. Windows 10 is a VM. I can connect to the internet within the virtual machines perfectly fine if I use NAT or bridged. But NAT network doesn’t work at all. I get an IP from DHCP for the NAT network but there is no internet access

EDIT: I just used

$ VBoxManage natnetwork add --netname 10.20.14-NAT --network “10.20.14.0/24” --enable

$ VBoxManage dhcpserver add --netname 10.20.14-NAT --ip 10.20.14.3 --netmask 255.255.255.0 --lowerip 10.20.14.200 --upperip 10.20.14.250 --enable

to create another nat network. I can ping from the Windows 10 VM to the kali VM, but Kali cannot ping the windows 10 VM. I can ssh into the windows 10 through kali as well as ping the host laptop and router through kali. But still no internet access.
The kali IP is now 10.20.14.200 and windows 10 vm is 10.20.14.201

I’m at a complete loss here