[Resolved] USB wireless adapter on virtual machine isn't recognized

I’ve been going through the Learn Ethical Hacking From Scratch course and have been excited to try out aircrack-ng on my own. I recently purchased a Kali compatible WiFi adaptor to use with aircrack-ng. I haven’t been able to use it though to scan for WiFi networks in monitor mode when using Kali in virtualbox.

The forums I read elsewhere said that using a wireless adapter with a VM to scan for WiFi networks isn’t possible since VMs virtualized the hardware to be a LAN connection.

In order to use aircrack-ng, would I need to either download it to my system then use it with the wireless adapter or create a live CD of Kali then use aircrack-ng and the wireless adapter? It sounds like there isn’t a way to use it on a VM.

it is possible to use wi-fi usb adapter on a vm. i’m using a vmware esxi (free, and old version of it) and i’m able to use a tp-link wifi card using the usb port.
i didnt try it yet with virtual box but, with vmware you have to “link” the usb device with the machine in the properties of the vm.
there is surely a way to do so with virtual box.

i just did a quick search on google and got 3 videos at the top of the request that show how to connect usb wifi adapter to virtual box

Thanks for your help, I should have thought of that sooner. I googled it and watched the video found here: https://www.youtube.com/watch?v=K1ETBeRQBs4. Following what you said and the video I went into the network settings of the Kali machine to mount the device. Unfortunately, it wasn’t detected by my computer. I thought maybe I had the USB in the USB 3 connector so I switched the virtualbox settings to try there but it still isn’t detected.

I have a Panda Wireless N600 dual-band wireless-N USB adapter. In order to get it working on my Debian machine, I worked with Panda support to get all the drivers installed and it works fine on my host machine.

In the Youtube video, he talks about manually adding it with the Vendor ID and Product ID. I don’t know what that is since it’s not showing up on my computer. I’ve looked on the packaging as well as the user manual. Maybe that’s something I should talk to Panda Wireless about getting?

once you’ve “connect” the usb port with the kali linux, did you try to unplug the usb device and plug it back after?

i fought with that for few hours with my setup (even reinstall all the vmware, kali few times). all i had to do is unplug it and plug it back. as far as i remember, the virtual machine had to be up

I just tried that but had the same result. Here is what I did.

  1. Started Virtualbox
  2. Plugged in my wireless adapter
  3. Went to the USB settings for the Kali Linux machine
  4. Attempted to connect my wireless adapter with Kali by adding a USB.
  5. My wireless adapter wasn’t detected on USB 2.0 or 3.0 ports (even though my host machine detects it and it’s connected).
  6. Unplug the wireless adapter and started Kali
  7. Once Kali starts, plug it back in. Still not detected.
  8. Restarted Kali, this time with the wireless adapter plugged in. Still, my USB wireless adapter isn’t detected.

Maybe I should look into how to manually add it since my host machine isn’t picking it up? Perhaps that will work?

i did some research and have a question for you.
did you install the “VirtualBox 5.2.0 Oracle VM VirtualBox Extension Pack” ?

if not, you should try that since it’s seem to be needed for “Support for USB 2.0 and USB 3.0 devices,…”
you may have to reinstall your virtual machine after this (just a guess, or at least, i would do it to be sure i’m not messing with a “persistent” problem)

I’m already running Virtualbox 5.1.3 and I’ve installed the extension pack for the same version as well. When I first installed this version of virtualbox, it said there were issues with USB 2.0 and 3.0 not being detected. After I installed the extension pack, those alerts went away. This was something I resolved before I ever had the wireless adapter.

Do you think I should update virtualbox and try everything over again with the new version?

i would defenetly do all the test with the newest version. just to be sure you are not working on a matters that have been resolved in the latest version.

I’ve updated to the latest version of virtualbox (5.2) and run through everything again with the same result.

Just to show you that the wireless adapter is working

I run ip add in the terminal and get this output:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp2s0f2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether 38:d5:47:9f:ec:e4 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 94:e9:79:17:5d:5f brd ff:ff:ff:ff:ff:ff
inet 192.168.0.15/24 brd 192.168.0.255 scope global dynamic wlp3s0
valid_lft 84461sec preferred_lft 84461sec
inet6 fe80::257c:b507:4aeb:3077/64 scope link
valid_lft forever preferred_lft forever
6: wlx9cefd5fe1a14: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 9c:ef:d5:fe:1a:14 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.16/24 brd 192.168.0.255 scope global dynamic wlx9cefd5fe1a14
valid_lft 86388sec preferred_lft 86388sec
inet6 fe80::2b5f:55db:b194:2582/64 scope link
valid_lft forever preferred_lft forever

Not sure why the labels for ethernet, internal wifi card and my wireless adapter are so strange but #2 is my ethernet, #3 is my internal wireless card and #6 is my USB wireless card.

When I go into virtualbox, I open the settings for Kali linux and go to Network settings. Currently it’s attached to a NAT network but when I switch it to bridged mode, I can see both my internal and USB wifi cards. Then I go to USB settings to attach my USB wireless adapter but when I click the add button, it shows no USBs available. I’ve tried this for USB 1.0, 2.0, and 3.0. I’ve also switched USB ports on my computer and tried the process all over again.

In kali, I ran ifconfig and got the ethernet address and the loopback address only.

ok!

i have to admit that i’m out of idea for the moment :frowning:

I reached out to Panda support to see if they had any ideas. They suggested that my host machine might be using the adapter so virtualbox can’t recognize it. They suggested turning it off on the host machine and seeing if virtualbox could recognize it then. I ran:

ip set link [wireless adapter name here] down

This turned off my wireless adapter. I went to the USB settings on virtualbox and tried to add a new adapter. Nothing was recognized. Bummer.

I’m out of ideas for the moment as well. I’ll keep searching but for the moment, I guess in order to get it set up, I’ll just have to use a live CD/USB and run kali and the wireless adapter off that.

Ok, the issue has been resolved. I posted my issue on the virtualbox forum. The answer was to:

Have a look at: USB Basics and Troubleshooting.

So I looked through there and I ran from the command line:

Id

This listed all the different groups on my computer. Then I ran:

groups [my username here]

I wasn’t a part of the vboxusers group

I added myself by running:

sudo usermod -a -G vboxusers [my username here]

Then I restarted my computer and my USB wireless adapter shows up and I successfully mounted it with Kali. Everything works now.

nice! i think this will help few user in the futur! :slight_smile:
nice digging on that matter

Could you make a video of it and attatch a link, im having the same problem and cant seem to find a solution, id really appreciate it, its been giving me a headache for days

To be honest, I’m not sure how to make tutorials like that. If you just run the code I posted on the command line, you should be fine

1st run:

groups

This will list all the groups you are a part of on your computer. You are looking for vboxusers. If vboxusers isn’t listed, run the following:

sudo usermod -a -G vboxusers usernamehere
Your username is the one that is used when you start the command line. Username@computername

Then restart and your USB adapter should show up in Virtualbox.

Codyjacks, you rock. That worked! Thank you!!!

Codyjacks, when I try running that command in a terminal, it comes up with an error; "usermod: group ‘vboxusers’ does not exist.’

Hi Zak,

What OS are you running? And what wireless adapter model do you have?

Hey AJS,

Currently I am running Kali (2019.4) on windows 10. The adapter I am using is the Alfa AWUS036NHA.

That’s why the above commands are not working for you, because they can work on Linux systems not on Windows, therefore, please make sure that you add the card to the USB list as shown in lecture 11. If you already did this step, then make sure that you don’t physically connect the card to the computer until Kali is fully booted, connect the card, then go to the devices menu (beside the file menu) >> USB >> Click your device.

If you’ve already done the above, then make sure that you’re using the custom ova image provided in the resources of lecture 5, it comes pre-installed with the required drivers and packages (assuming that you’re taking Zaid main course) and it’s well suited to follow along. You just plug the adapter and add it as shown in lecture 11, it should work out of the box.