Social Engineering Course (Errors on both Veil & FatRat)

I’m going through Zaid’s Social Engineering course and I seem to be running into quite a lot of errors going through the install process of Veil Framework and the generating backdoor in TheFatRat.

When I install Veil it comes up with an error saying “Failed with installing wine (2): 0”

I then moved onto TheFatRat and got this error when trying to generate my backdoor:

“cat: powershell_attack.txt: No such file or directory
rm: cannot remove ‘unicorn.rc’: No such file or directory
mv: cannot stat ‘powershell_attack.txt’: No such file or directory”

“There was an error creating the backdoor”

I tried googling both these errors but have had no luck finding the answers… All i could find was people saying to use a fresh Zaid’s custom Kali (That’s what i’m using) and still running into errors.

Normally help or extra info is provided when there is the possibility of errors but nothing has been provided in the course. Maybe the info in this course is outdated?

Any help on these issues would be appreciated!

Thank you

error fatrat

I suggest you use latest version of Kali instead of Zaid’s one. The Kali he is using is 2018 in his video. Many things change when a new version is released. Try using latest version of Kali and the latest version fo veil from their official repo: https://github.com/Veil-Framework/Veil. Also, look at the Issues tab on their GitHub repo. There are many issues reported so if there is any solution to that then you will find it here: https://github.com/Veil-Framework/Veil/issues. If any issue is still not resolved then it is likely that the developers of the Veil are looking into this.