[Solved] Issue With TCPDUMP

When I run tcpdump -i any dst net and not src net i get non-network bits set in error.

Change the 0. You cant set a range that isn’t possible. For example tcpdump -i any dst net and not src net

Should work.

Hi Nathan the router is so if it change it to that will be a subnet that doesnt exist.

I also received the same error when i used non-network bits set in

Tcpdump is complaining that given a subnet mask of /24 your IP range is invalid. But it looks ok. What is the subnet mask on your network?






The .1 could be what it sees as out of range.

I have Kali in Bridged mode, when i run ifconfig the netmask is the inet local ip is of the kali machine and the broadcast is when i tried. tcpdump -i any dst net and not src it works is that properly capturing the proper network? I am seeing arp traffic from my router to my cable provider.

Yes technically is incorrect. But works with some tcpdump versions. not src net will not capture your local traffic now as the command is designed.

I really appreciate it Nathan! It does work I have only found ARP requests and now that i add the no arp i see some google safe browsing requests to my kali box but nothing else. Anyone that is serious about protecting their home network MUST take your courses!

Thanks! oh yes those safe browsing requests! Everyone everywhere is talking to Google!!