USB Wireless adapter (AWUS036ACH) not connecting to network

I just purchased the Alfa AWUS036ACH wireless adapter, and installed it. It connects in Windows 10, but I can’t get it to connect to the same network in the Kali VM. I use the same network credentials in the VM that I use in Windows to connect to the same network, but the network (Orbi router) refuses to authenticate when trying to connect from Kali. I’m likely overlooking something, but I’ll be damned if I can figure out what it is. The network connect dropdown lists my router as expected, and everything appears normal. The Kali Devices menu lists ‘Realtek 802.11n NIC’. I’ve tried first disconnecting the wired connection, but it doesn’t change anything.
Stuck again!

Just noticed something else … When the Kali VM is running, the wireless adapter is blocked in Windows. I actually wondered about this but would expect the adapter to be connected to the network when blocking Windows. So the scenario is Kali is on the network via the wired connection, and the Windows wireless connection is not functional. When I shutdown the VM, the wireless adapter operation returns to normal.

Hi Irwin

Have you figured this out?

Stoney

Hi Irwin,

Zaid made a video on installing the drivers for this adapter, the steps are similar but please keep in mind these notes:

  • Please try to install the driver on a fresh install,

  • Connect the adapter directly to the PC port after Kali FULLY loads, and after you log in as root.

  • Experiment setting the adapter to USB 3 and 2 in Kali USB settings in VBox with different USB ports on your PC.

Here’s the video driver installation:

Note: If you’re taking Zaid course, then you should install the custom ova 2020 image which comes pre-installed with the required packages/software to follow along with the ACH adapter driver also pre-installed.
https://zsecurity.org/download-custom-kali/