Veil framework

Too many errors installing veil framework.
What do i do?

What type of errors are you getting?

Please help resolve these

which kali version do you use?

Kali 2020 x64

did you try this one?

I use this only

I found this on Udemy.:

Please ensure you are running the latest v1.2 of the custom kali image.
If yes then run the following
Please ensure a stable internet connection since any interruption in the network can break Veil dependencies.

Revert to a snapshot where Veil is not installed and then install it using these commands:

apt update
apt -y install veil
/usr/share/veil/config/ --force --silent

Then run veil from the console directly using:

and this:

Could you please try to run:

apt-get install wine32

Then run the installer again.

I am having so many errors and challenges when trying to install veil - can anyone HELP PLEASE

I am having errors too! I installed veil via apt-get install veil. I then tried /usr/share/veil/config/ --force --silent. It keeps saying to install wine32 but when I try to apt-get install wine32 and apt-get install wine32:i386! I get an error saying following packages have unmet dependenices wine32:i386 it also says unable to correct problems, you have held broken packages! Has anyone figured this out?? This is being tried on a fresh install of zaids virtual image! I have tried all the ways listed and still nothing! Any help would be greatly appreciated!

A post was split to a new topic: Veil backdoor Path Not working

I Finally manage to install Veil but not on the custom kali provided by Zaid but on kali 2021 version.

  1. Go on GitHub - Veil-Framework/Veil: Veil 3.1.X (Check version info in Veil at runtime) page
  2. Follow the steps mentioned there.
  3. After installation get complete run as veil
  4. It will prompt that veil is not installed do you like to install, do Y.
  5. Again it will show you some error and will give you a path and solution to execute.
  6. Run that path, your Veil finally will get installed.
1 Like

@ajinkyatakawale Thank you for the update. I will give it a try.