Veil installation on Raspberry Pi

Hello all,
I’m trying to install Veil in a RPI3b+ machine running Kali Linux 4.14.93-Re4son-v7+.

I cloned the git repository, but when I launch the setup.sh command I have the following error:

[ERROR] Your architecture armv7l in not supported

Does it means that Veil cannot run on a RPI?