Whats wrong with my python installation dont understand

check this error
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at Release process - pip documentation v21.2.dev0 pip 21.0 will remove support for this functionality.
please help

Python 2.7 is outdated. You should update your python to 3.x. If you are using Linux then you should have python 3 installed and you can access it by typing “python3”. If it is not installed then follo these steps to install it - Installing Python 3 on Linux — The Hitchhiker's Guide to Python