Why does virtualbox only have 32-bit option on my windows

why does virtualbox only have 32-bit option on my windows pc

That means that VT-x/AMD-v isn’t available to VirtualBox.

Usually that means that feature is disabled in your BIOS. Go into the computer’s BIOS/UEFI and check the CPU section for “Intel virtualization technology” or something similar, and enable it if it’s disabled.

If it was already enabled, then try disabling any anti-virus software you have running - sometimes that can interfere with VirtualBox.

Another possibility is that Hyper-V or another virtualization program is already active and monopolizing VT-x. Check “Windows Features” for Hyper-V, Windows Sandbox, or anything that mentions virtualization, disable them, then shut the computer down and boot it back up to try VirtualBox again.