Wifi adapter works in monitor mode but impossible to connect to a network

With my ALFA AWUS036ACH antenna (connected via USB to Kali in Virtualbox) in monitormode, I can find all the wifi-networks in my neighbourhood. So I’m sure the drivers are ok. With ifconfig I can see that wlan0 exists.
But connecting to my home wifi-network seems to be impossible. I’m able to fill in the password but it won’t connect. Could the reason be dualband wifi? Or is there something else going on.
Thanks in advance for your time!
Regards,
Marc

1 Like

Hello I had the same problem right now I was trying to connect it to my home wifi but I kept getting an error so I looked online and well I found something that helped try closing the VM and go to the settings and check if the adapter is still under the USB settings when I checked it wasn’t so I added it back and it worked now I’m connected hope it works for you :slight_smile:

@marman365 was this issue solved? If yes, please let me know. I have the same wireless adapter and the same experiences you described.