Windows 10 for VirtualBox

I’m doing the the ethical hacking course and I’m trying to install windows 10 on virtualbox, however when I start the VM, the display appears to be loading extremely slowly / with lag. I’ve tried increasing processor from 1 to 2, increasing video ram to128MB, enabling hardware acceleration etc. Nothing seems to be working. I’ve attached an image of the default settings that I’m using for reference:

I’ve used the default settings that Zaid has used, and this is what i’m getting in the task manager when the VM is running:

Based on how much ram you have, 2048 MB might be too much or too little. Shut down the machine before trying to change how much ram you give it. discarding the machine(The discard button in virtualbox) works too. Try changing the ram that you give the virtual machine if its causing issues with lag.

Thanks for the suggestion. I have tried to increase RAM to 4096 MB and also decrease RAM but in either case the lag is still there and the windows machine takes a very long time to load up. There’s no noticeable difference in either case. The startup loading icon is very slow and eventually the VM shuts down. I have 16GB RAM installed on my laptop and on task manager, it shows that I have 9GB RAM available so I don’t think RAM is the issue. I’ve also tried to reinstall virtualbox and the windows 10 image but I got the same problem.

With 16 GB base RAM and 4 GB given to VM, I don’t think the memory si the issue if you are still getting lags. I would suggest you to completely uninstall the Virtualbox (delete the files where VM is created also) and also download the Windows VM image again. Another thing to try is to use VMWare Player and see if it works there or not.

I managed to solve the issue by turning off hyper-v which was interfering with virtual box. If anyone else has this issue, have a look at this thread:

1 Like

I have the same issue. I tried following the instructions in the link but I don’t seem to have hyper-v installed. What else could be causing the issue?

Also, it used to run normally, then I took a break from the course and suddenly it’s extremely slow.

Ah sorry, sorted now thanks. I missed the part where they said to turn off Windows Hypervisor Platform and Virtual Machine Platform. Working fine now. Thanks for the link